T-Splines
T-Splines

Current version

Download the current version.

Autodesk T-Splines Plug-in for Rhino: v4.0 Download

Featured threads

The links below lead to some of our favorite forum threads.

052775 052099

29164 052640

29164 29164

052346 052775


See more featured threads.

Webinars

Date Topics  
7/09 Creating stunning jewelry designs with T-Splines View
5/07 How to approach modeling with T-Splines View
3/07 Carl Bass reintroduces T-Splines for Rhino View
6/21 Transitioning from NURBS to T-Splines View
12/07 Footwear modeling with T-Splines 3.3 for Rhino View
11/29 New T-Splines reverse engineering tools View
10/28 How T-Splines changed my aproach to making jewelry in CAD View
09/29 Modeling a water gun View
09/07 Car modeling:
Parts 1, 2, & 3
View
07/06 tsElements intro
hosted by Novedge
View
06/22 Free-form Architecture View
06/15 TS Pipe command View
06/08 T-Splines for Rhino intro View

Cannot toogle back to smooth mode

A support and feedback forum for Autodesk T-Splines Plug-in for Rhino users.

Cannot toogle back to smooth mode

Postby aoborras » Tue Aug 09, 2016 9:38 pm

Hey so I cant toogle back to smooth mode for some reason.I noticed though that I have a few red Highlighted edges but I don't know what that's about. I've gone through a few threads looking for a solution and I've tried the following: Searching for naked Edges, but yielded no results, Used the tsLayout command and played around with stars and points but still cant switch back to smooth mode. I will admit this is my second attempt at modeling with t-splines so I am a noob :D
aoborras
Poster
 
Posts: 3
Joined: Tue Aug 09, 2016 9:22 pm

Re: Cannot toogle back to smooth mode

Postby JSantocono » Wed Aug 10, 2016 6:32 am

Hi aoborras.

For what you are saying the problem is with the topology. There can be several reason why you get red dots when you run the tsLayout :tsLayout: . Impossible to know without seeing the model.
A solution might be to run tsLayout and click on the red dots to change them into T-Points or StarPoints. There is also an option for automatic fixing inside the command.
If this is not working for you I may need to see the file in order to tell you what is going on. Can you post the file?
JuanS
User avatar
JSantocono
Poster
 
Posts: 988
Joined: Thu Jan 03, 2008 10:18 am
Location: Argentina

Re: Cannot toogle back to smooth mode

Postby aoborras » Wed Aug 10, 2016 6:23 pm

I had tried that but I didn't get it to work, Here's the file, thank you so very much
Attachments
sunglases.3dm
(4.62 MiB) Downloaded 137 times
aoborras
Poster
 
Posts: 3
Joined: Tue Aug 09, 2016 9:22 pm

Re: Cannot toogle back to smooth mode

Postby JSantocono » Thu Aug 11, 2016 6:50 am

Hi.
It seems that for some reason you had two surfaces stacked on top of each other generating a non manifold T-Splines mesh.
The solution in this case is to run the tsWeld :tsWeld: and select all the verts on the surface.

Here is the file fixed.

JuanS
Attachments
sunglasesFixed.3dm
(4.73 MiB) Downloaded 130 times
User avatar
JSantocono
Poster
 
Posts: 988
Joined: Thu Jan 03, 2008 10:18 am
Location: Argentina

Re: Cannot toogle back to smooth mode

Postby aoborras » Thu Aug 11, 2016 4:38 pm

oh wow! Woops, thank you soo much :D my question then would be how do I avoid that in the first place?
aoborras
Poster
 
Posts: 3
Joined: Tue Aug 09, 2016 9:22 pm

Re: Cannot toogle back to smooth mode

Postby JSantocono » Fri Aug 12, 2016 7:06 am

Well, you just to be careful in order to avoid this type of problem.
In general, this happens when you double extrude without realizing... Or having duplicated surfaces and welding wrongly both.
As soon as you have a red vert or edge you have problems.

JuanS
User avatar
JSantocono
Poster
 
Posts: 988
Joined: Thu Jan 03, 2008 10:18 am
Location: Argentina


Return to Autodesk T-Splines Plug-in for Rhino modeling

Who is online

Users browsing this forum: No registered users and 14 guests

 
cron